Format Encrypted SAS SSD (HGST) to use in Unraid or elsewhere

Acquired a cheaper HGST SAS SSD and tried to throw it into Unraid. When I tried to format it to xfs or btrfs I was unable to. I then went to my handy sg_format tool to format it but was finding myself facing some errors like “Format unit command: Data protect, type: sense key; write protected media?” and ultimately the format unit failed. @gimpyb sent me this link: and I did not properly read the whole thing. The key is formatting these drives lay in the first few sentences, “You’ll be able to hook them up and see that they show up as /dev/sdX, but you won’t be able to do anything with them (such as read/write or partition).”

So, invoking sg_scan -i showed that my drive was sg13 and now, when I went to run my command sg_format --format --size=512 /dev/sg13 it worked just fine. Then I was able to format to xfs and throw into a cache pool.

Lesson, yet again, is to read.

Good catch. Was a typo!

@eph, which drives were these?

These were 3.2TB SAS SSD HGST; pretty sure these